Share » Forums » Install & configuration » Serious problems upgrading from 3.6.2...

Serious problems upgrading from 3.6.2 to 3.8.0

Serious problems upgrading from 3.6.2 to 3.8.0

Wednesday 10 May 2006 1:09:51 am - 7 replies

Modified on Wednesday 10 May 2006 1:25:55 am by Daniel Arnrup-Ă˜ien

Author Message

Theodoros Papageorgiou

Friday 12 May 2006 1:20:32 pm


1) Is php-cli installed on your server?

2) You need to run the updatemultilingual.php and configure the correct languages in your site.ini.append.php.

Web Development

Dominik LEE

Friday 26 May 2006 7:05:04 am

Hi everyone,
I've been using Ezpublish 3.6 for almost 1 year without big trouble.

Yesterday, i upgraded to 3.8.0 following the instructions.

I had the same problem as Daniel : <i>Kernel (3) - object is unavailable</i>

The scripts worked for me with this output :

php -C ./update/common/scripts/updatemultilingual.php -s ws
Have you backed up your database? If not, press Ctrl-C and back up your data!
The default language for your siteaccess is 'fre-FR' and will be used as the initial language for all your objects.
The script will use the following database settings:
  user: <***>, password: <***>, server: <localhost>, socket: <>, name: <dbname>, charset: <iso-8859-1>
You have now 10 seconds to break this script (press Ctrl-C) if the settings are incorrect.
Step 1/6: Removing the drafts:
Step 2/6: Identifying languages used on the site:
  language: fre-FR (id 4)
  language: eng-GB (id 2)
Step 3/6: Fixing the ezcontentclass table.
Step 4/6: Fixing the ezcontentobject_name table.
Step 5/6: Fixing content object versions and attributes. Please be patient, this might take a while...
Step 6/6: Fixing content objects. Please be patient, this might take a while...
Content-type: text/html
X-Powered-By: PHP/4.3.10
Set-Cookie: eZSESSIDws=fd916db6c22306b383ae8f8370558bfe; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache

The problem remains after clearing cache several times. I also checked all language settings in site.ini.append of siteaccess

I even built a new test site under 3.8.0 which seems to work very well.

I guess there is a problem in accessing the database, but can't figure it out.

Any help would be greatly appreciated.


Tim Dickinson

Friday 26 May 2006 7:15:06 am

I only got that problem before running the updatemultilingual.php script.

I believe you are supposed to run the script with the admin siteaccess (mine was news_admin for example), so I just ran the script using SSH with:

cd /home/MY_USERNAME/public_html
./update/common/scripts/updatemultilingual.php -snews_admin

That is the path to my ez instalation in the first line and running the script in the second.

Is ws your admin siteaccess?

Tim - Ad network news and reviews - Website publisher guides, tools and news - Make better music

Dominik LEE

Friday 26 May 2006 7:22:19 am

HI, thanks for that quick answer

I executed the script for both ws and ws_admin (which is the admin access) with no success.

Just tried a minute ago with no change.

My command line :

 php -C ./update/common/scripts/updatemultilingual.php -s ws_admin

After building a test site (that I built after deleting override/site.ini.append and using the wizard), I managed to connect to the new database using my previous configuration (just by changing the name of the database in siteaccess/ws/site.ini.append.php.
Does it mean my odl database is corrupted ?

Dominik LEE

Friday 26 May 2006 1:01:52 pm

Problem partially solved. Somehow, several siteaccess files where set to "utf8" instead of "iso-8859-1". So changing that brought back database connexion.

Now the problem is that only "folder" class data appears on the admin interface and on the website. Still can't figure out why.

SQL debut output gives :

SELECT data, user_id, expiration_time FROM ezsession WHERE session_key='c8d274f581378c6a8f43a96e2912337a'

If anybody has an answer to this.


Eivind Marienborg

Wednesday 16 August 2006 9:20:18 am

I have completed the steps outlined in the upgrade manual for 3.8.0. The following two problems present themselves:

1) the updatemultilingual.php script throws a fatal error but doesn't generate anything in the logs.

2) the content structure is messed up. It is completely empty in the administration interface. However, I can see all the nodes if I go to Sections -> Standard, but I can't click on them without getting a kernel (3) error (object not available). This is NOT related to the ShowClasses[] directive in contentstructuremenu.ini, as I have modified this to show all classes.

I can log in using various user accounts, but they are also unavailable as part of the content structure.

I don't know if the problems are a result of the updatemultilingual.php script failure, or if it's something else. The Regional settings of the siteaccess are also updated with the new language parameters. The database was updated without problems using the script provided with the 3.8.0 distribution.

Did you find a sollution to this? I'm struggling with the same issues when upgrading to 3.8.3.

Bertrand Dunogier

Thursday 17 August 2006 2:35:25 am

There is something I've noticed in the upgrade script's execution: at the end you have the HTML headers... this means you are using the CGI version, not CLI. It may be an issue.

Use php -v to determine accurately what PHP version you're running. Compile PHP CLI if necessary, using the same options as the module version, and try again.

Bertrand Dunogier
eZ Systems Engineering, Lyon

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu